Online Reservation System:
Software, database & hosting

Why are emails not deleted from the server after retrieval?

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Symptom

You have configured a terminal to retrieve e-mails via the POP3 protocol and have set that retrieved e-mails should be deleted immediately or after a certain waiting time from the mail server. The mails are obviously not deleted from the mailbox.

 

Cause

For its part, the server does not automatically influence whether a message is deleted in the mailbox or not. It only acts according to the instruction that mail programs that connect to the mail server are sending. The issue cannot be solved by settings on the server.

Therefore, first check whether you have really activated the option of your mail program to delete retrieved mails from the server. Often a checkmark is missing in the right place of the mail program configuration.

If everything is configured correctly, other devices have access to the mailbox via IMAP protocol, e.g. a smartphone or another computer, and are synchronizing the mailbox. When your computer, which retrieves the messages via POP3, deletes the mail, the other devices that use IMAP synchronize the mailbox and, if necessary, restore deleted data from their own cache.

 

Solution

The configuration of all devices that have access to the mailbox must include that e-mail messages should be deleted after retrieval. Otherwise, any participating devices might restore deleted mail from the mailbox.

 

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